How to unlock Mio Moov M410 (to run AutoMapa)

Installing AutoMapa on this device is a little bit tricky. It’s not enough to just run a graphical installer, it won’t set proper program paths in configuration files. So how to do that manually? How to make AutoMapa work on Mio Moov m410?

It’s not necessary to install custom navi panel (like VisualGPS). You can do that if you like, but there is another method, based on editing a few lines of text in configuration files. I’m going to focus on latter method in this post. Here’s what you got to do:

Step 1) Run AutoMapa installer normally, install the program on your device flash disk.

Step 2) Do not run patching utility to crack AutoMapa, pay for the license! It’s worth it.

Step 3) Configure proper paths in appstartupsec.ini

If you turn on your device after AutoMapa installation, it will run default MapaMap software. We have to explicitly tell the device where to find AutoMapa executable.

Open file Program Files/Navman/appstartupsec.ini from Mio flash disk (using any text editor, standard Windows Notepad will do). It should contain a few lines of text for Windows CE6 startup processes configuration:


AppStartupSec]
TurnOffConsole=TRUE

[Process1]
RelativePath=TRUE
ProcessFile=SmartST_CE.exe
DefaultCmdLine=
BootCmdLine=
StartOnBoot=1
MaxRestarts=3
TreatCloseAsError=TRUE
Major=TRUE
WindowName=SmartST_CE
MaxCloseMessages=10
KeysToForward=0x7A,0xC4
KeysToBoot=

[Process2]
RelativePath=FALSE
ProcessFile=Program Files\Screen Saver\VideoShow.exe
DefaultCmdLine=
BootCmdLine=
StartOnBoot=0
MaxRestarts=0
TreatCloseAsError=FALSE
Major=FALSE
WindowName=VideoShow
MaxCloseMessages=10
KeysToForward=0x7A,0xC4
KeysToBoot=

Now change the highlighted line:

ProcessFile=SmartST_CE.exe

to:

ProcesFile=<path to executable>

In my case it was:

ProcessFile=AutoMapa EU/AutoMapa EU.exe

but for you it might be different, depeneding on AutoMapa version and selected installation options.

If you want to use custom Navi panel (like VisualGPS, this line should contain your panel’s executable path instead).

Step 4) Configure PowerButton.exe

Great, now when you turn on the device, AutoMapa starts automatically. But when you turn off Mio Moov, you’ll find out that te ‚power’ button stopped working. How to fix that? By running custom process PowerButton.exe (in addition to navigation software). This little utility would handle system event for pushing the power button and and trigger Windows CE shutdown.

Download PowerButton.zip, unzip it, and place both PowerButton.exe and PowerButton.ini in any directory on the device (you can place them on root or anywhere you feel like).

Now we have the utility, but we still got to tell the system, that it needs to run it.

Open appstartupsec.ini once again and add following lines at the end of file:

[Process3]
RelativePath=FALSE
ProcessFile=Program Files/PowerButton.exe
DefaultCmdLine=
BootCmdLine=
StartOnBoot=1
MaxRestarts=0
TreatCloseAsError=FALSE
Major=FALSE
WindowName=VideoShow
MaxCloseMessages=10
KeysToForward=0x7A,0xC4
KeysToBoot=

Change the highlighted line:

ProcessFile=Program Files/PowerButton.exe

to correct path to your PowerButton files.

step 5) Drive safely!

That’s it! Everything should work now :)

Mio Moov M410 running AutoMapa

Reklamy
8 comments
  1. Mike said:

    I did carefully all described above, but after changing appstartupsec.ini and reboot my M410 stays on usb-connection screen.

  2. Mike said:

    Problem solved: only thing to do – move automapa folder from root folder to Program Files and correct path in appstartupsec.ini to Program Files\AutoMapa EU\AutoMapa EU.exe and it works great. Yuppiiii :)

  3. george said:

    The power button is not working:” A system shell must be present to support executing folder paths or shell extensions.” it says.
    Please advice!

    Thank YOU!

  4. Stoica Petru Cezar said:

    George , change the highlighted line in this way : ProcessFile=Program Files\PowerButton.exe and will work.

  5. DJRuTeK said:

    In my mio automapa wont work, i have done everyting… when i change back to SmartST_CE.exe it works, but when i change to Program Files\AutoMapa EU\AutoMapa EU.exe there is only usb-connecting screen. I tried forwardslashes, I tried add slash on the beginning of patch. I also tried run wceAM.exe . Any idea?

    • Try change

      [Process1]
      RelativePath=TRUE

      to

      [Process1]
      RelativePath=FALSE

      • DJRuTeK said:

        Solution works! Thanks!

  6. Attila said:

    so fair:

    [Process1]
    RelativePath=FALSE
    ProcessFile=\\..\\My Flash Disk\\primo\\SmartST_CE.exe
    DefaultCmdLine=
    BootCmdLine=
    StartOnBoot=1
    MaxRestarts=3
    TreatCloseAsError=TRUE
    Major=TRUE
    WindowName=SmartST_CE
    MaxCloseMessages=10
    KeysToForward=0x7A,0xC4
    KeysToBoot=

    [Process3]
    RelativePath=FALSE
    ProcessFile=\\..\\My Flash Disk\\Program Files\\PowerButton.exe
    DefaultCmdLine=
    BootCmdLine=
    StartOnBoot=1
    MaxRestarts=0
    TreatCloseAsError=FALSE
    Major=FALSE
    WindowName=VideoShow
    MaxCloseMessages=10
    KeysToForward=0x7A,0xC4
    KeysToBoot=

Skomentuj

Wprowadź swoje dane lub kliknij jedną z tych ikon, aby się zalogować:

Logo WordPress.com

Komentujesz korzystając z konta WordPress.com. Wyloguj / Zmień )

Zdjęcie z Twittera

Komentujesz korzystając z konta Twitter. Wyloguj / Zmień )

Facebook photo

Komentujesz korzystając z konta Facebook. Wyloguj / Zmień )

Google+ photo

Komentujesz korzystając z konta Google+. Wyloguj / Zmień )

Connecting to %s

%d blogerów lubi to: